Project

General

Profile

Bug #983

Segmentation violation on start

Added by vvv1 over 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
2012-02-23
% Done:

100%


Description

Doomsday 1.9.7 build365 or newer generates "Segmentation violation" just after start. My OS is Windows XP Professional SP2 32 bit. Doomsday 1.9.7 build364 or older works fine for me.

Labels: Startup

History

#1 Updated by skyjake over 10 years ago

Without knowing what you're trying to load it's difficult to say what could be going wrong.

Could you please attach the following from your Frontend/Snowberry runtime directory: Options.rsp, doomsday.out

Are your video card drivers up to date? I assume since you're on XP your computer is a bit older -- make sure the video card supports OpenGL 1.4 or newer.

#3 Updated by vvv1 over 10 years ago

Finally I was able to start newest builds. I started Doom from "I:\Games\Doomsday\snowberry\runtime" with the following options:
I:\Games\Doomsday\bin\Doomsday.exe -wh 1280 1024 -sbd -game jdoom -iwad C:\GAMES
\DOOM\DOOM.WAD
It works fine with build 364 and older. But generates "Segmentation violation" with newer builds. I replaced "-sbd" with "-bd ..\.." and changed "-game jdoom" to "-game doom1-ultimate". "Segmentation violation" box appears if engine could not find doomsday.pk3 file due to incorrect basedir. I suppose, "-sbd" behaviour was changed in build 365.

#4 Updated by danij over 10 years ago

The issue with -stdbasedir (-sbd) not working as expected on Windows should now be fixed for Monday's build.

Also available in: Atom PDF