Project

General

Profile

Bug #940

[Doom] Exit switches play the wrong sound

Added by vermil over 11 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2010-11-10
% Done:

100%


Description

Summary says all. In Beta 6.9 they play "swtchx" when they should be playing "swtchn".

Labels: Sound Effects

History

#1 Updated by danij almost 9 years ago

Another instance where the source says one thing but does another due to a bug. The original P_ChangeSwitchTexture has a special case for exit switches which is supposed to always play swtchx for exits using line special 11. However the caller (in this case P_UseSpecialLine) short circuits this logic by specifying that it is a non-repeatable action. So in other words, the special case is never actually hit and swtchn is played (the default sound).

Clearly it was intended that swtchx was to be played.

Fixed for the upcoming 1.9.0-beta6.10

Also available in: Atom PDF