Project

General

Profile

Bug #931

[Doom] Freeze completing TNT::MAP30 with jDUI

Added by danij almost 12 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2010-09-08
% Done:

100%


Description

dengine.net user Searinox says:

I have not been using any previous versions of DE so I cannot compare to previous experience... I have set up Doom1+Ultimate, Doom2, and Final Doom on this engine. I was able to play through and finish all the games except one. For some reason, completing level 30 of Final Doom - TNT Evilution freezes up the engine. I managed to narrow it down to one addon - the doom hires UI, aka jDUI. Without this addon everything works well. The problem is that this addon has been used by many people over and nobody complains of issues.

There is one more case of weird behaveior with this bug. If I switch resolutions and/or windowed mode DURING the engine's running, the problem no longer occurs. Note that STARTING in windowed doesn't affect the problem, one has to change resolution WHILE the engine is running. After that the level always completes as expected. Suspecting a conflict I used Snowberry to try and change the order of addon loading. I first put the UI on top, then on the bottom. No effect.

I am clueless as to why DE is doing this. The addon may be found on this page http://forums.newdoom.com/showthread.ph ... 76&page=18 as a megaupload link.

I tried inspecting doomsday.out but it records nothing regarding the problem. Whenever the game freezes, it's using up 50% of my processor, which is to say that if I had a single core it would be using 100%. I used Process Explorer to spy on the doomsday.exe process and I found the following thread to be the cause of the hog: doomsday.exe!curl_formget+0x9b88. I'm hoping this provides some useful info.

Labels: Data

Also available in: Atom PDF