Project

General

Profile

Bug #884

Heretic E3M4: teleport to E3M9: free pointer without ZONEID

Added by kambi over 12 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2010-04-03
% Done:

100%


Description

Heretic E3M4 (the azure fortress): entering the teleport to the secret level E3M9 makes a screen "now entering" without any title or arrow (like deng doesn't know new level's title), and (after clicking on "now entering" screen) deng crashes with

P_LoadMap: "E3M10"
ERROR Z_Free: Attempt to free pointer without ZONEID.

Note that above suggests that deng tries to load E3M10, not E3M9 --- possibly this is the cause of all the problems?

100% reproducible here. Attaching screenshots showing the location of the teleport (heretic-001.jpg, heretic-002.jpg), savegame right before entering the teleport (HticSav1.hsg), and full console log (doomsday_heretix.txt).

Using instead the normal exit to non-secret E3M5 (the ophidian lair) works fine.

Using cheat code "engage39" works fine also.

I also tested inside dosbox, running original DOS heretic with the same wad, and it doesn't crash --- I go to the E3M9 called "the aquifer".

This is on Linux i386, doomsday 1.9.0-beta6.8-lenny2, jheretic 1.4.7.
Installed from Debian Lenny repository on http://www.dengine.net/linux, although my actual system is mostly Debian squeeze (testing).

OpenGL is fglrx 8.12 (last working fglrx for ATI Mobility Radeon X1600).

Labels: jHeretic

Also available in: Atom PDF