Project

General

Profile

Bug #871

Significant CPU cache misses with fakeradio enabled

Added by danij over 12 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
2010-03-10
% Done:

100%


Description

When fakeradio is enabled Doomsday is currently suffering significant CPU cache misses when doing the setup needed to call Rend_RadioSegSection in doRenderSeg. Obviously the problem is exacerbated by the complexity of the map geometry in-view.

Note that this problem has already been resolved in the mapcache branch.

I'm adding this tracker item merely to document/record the issue.

Labels: OpenGL Renderer

Also available in: Atom PDF