Project

General

Profile

Bug #861

Compile error in sys_window [win32]

Added by arclore over 12 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
2010-01-27
% Done:

100%


Description

In sys_window.h (engine/port/inc) the declaration of the struct ddwindow_t defines the members *winTitle, *winText, and *winCommand only for UNIX. But in sys_sdl_window.c (eng/port/src, line 585), the function Sys_DestroyWindow attempts the following:

delwin(window->console.winTitle);
delwin(window->console.winText);
delwin(window->console.winCommand);
endwin();
window->console.winTitle = window->console.winText =
window->console.winCommand = NULL;

On Win32, this causes a fatal error on compile, since these members do not exist.

Labels: Build System

History

#1 Updated by danij over 12 years ago

Not a bug. It would appear you are using the wrong source files. Doomsday on Windows does not use SDL for windowing. You should be compiling engine/win32/src/sys_window.c instead.

Based on this report I would guess that you are still trying to compile using cmake. As I have said; this won't work as it not setup for this environment.

Also available in: Atom PDF