Project

General

Profile

Bug #852

[Hexen] Firing wand down large z-depth causes segfault

Added by arclore over 12 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2010-01-12
% Done:

100%


Description

At the end of Seven Portals, there's a watery abyss with 4-6 Afrits way down at the bottom. If you use nearby Wings of Wrath to float out into the middle of the gap, look down, and try to shoot them with the Mage's Wand, after a few shots it produces a Segment Violation.

Labels: jHexen

History

#1 Updated by danij over 12 years ago

Upon investigation I tracked this down to p_intercept.c #103:

intercepts = Z_Realloc(intercepts, maxIntercepts *= 2, PU_STATIC);

Rather obviously not right. Out of interest I decided to look back through our history and it would seem this particular bug has been around since at the very least the beginning of our project history - the initial checking back on 2003-02-26!

The fact that has managed to go unnoticed and undetected this long is mind boggling...

Fixed for 1.9.0-beta6.9

#3 Updated by danij over 12 years ago

I does make me wonder whether this (zone heap corruption) could be THE cause of so many unsolved obscure bug reports.

Also available in: Atom PDF