Project

General

Profile

Bug #849

Sound effects lower pitch and longer at higher frequencies

Added by eunbolt over 12 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Defect
Target version:
Start date:
2010-01-08
% Done:

100%

Tags:

Description

in the pk-doom-sfx-20090830 addon pack
the files sound deeper and seem longer than they are than if you are playing it in a different audio player
dspdiehi.wav is 256kp/psec @ 32kHz
maybe deng doesn't support the frequency?

Labels: Sound Effects

History

#2 Updated by danij over 12 years ago

We should compare results with those of the DirectSound plugin to determine whether this is our problem or SDL_mixer's (I'm inclined to think the latter).

#4 Updated by danij over 7 years ago

Apparently, this issue persists in the current release, at least with playback via FMOD.

#5 Updated by danij over 7 years ago

  • Status changed from Closed to In Progress
  • Target version changed from 1.9.0-beta6 to 42
  • % Done changed from 100 to 50

#6 Updated by danij about 7 years ago

  • Target version deleted (42)

#7 Updated by skyjake about 6 years ago

  • Status changed from In Progress to Progressed

#8 Updated by skyjake over 5 years ago

  • Tags set to SFX, Audio, Resources
  • Category set to Defect
  • Target version set to 2.1 (Late 2018)

#9 Updated by skyjake over 3 years ago

  • Status changed from Progressed to Resolved
  • Assignee set to skyjake
  • % Done changed from 50 to 100

Testing with 2.1 and the FMOD low-level API all SFX frequencies, including 32 kHz, seem to be working as intended.

#10 Updated by skyjake over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF