Project

General

Profile

Bug #829

Weapons Automatically Picked Up at Start of Map

Added by sonicdoommario over 12 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
2009-12-02
% Done:

100%


Description

If a player is standing right on top of an item at the start of a level, the player does not pick up the item until he moves. However, in the 1.9.0 betas, the items are automatically picked up when the map starts. Two examples of this are the Backpack in Doom II Map30 and the Shotgun/Backpack in Alien Vendetta Map07. The behavior was fine in Doomsday 1.8.6.

Labels: Gameplay

History

#1 Updated by danij over 12 years ago

This is not a bug. It is a deliberate change to the original behavior. When a mapper places objects directly on top of the player start position their intention is that the player is given them to begin with but due to flawed logic in the original games, they won't be picked up until the player moves.

Also available in: Atom PDF