Project

General

Profile

Bug #818

Plutonia 2 Dehacked Not Read

Added by sonicdoommario over 12 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2009-11-15
% Done:

100%


Description

Doomsday loads with Plutonia 2's Dehacked file but even when it is loaded, the story texts are not replaced. Other dehacked files, such as Alien Vendetta, read and replace the story text properly.

Labels: Data

History

#1 Updated by sonicdoommario over 12 years ago

Yes, I am loading it under the Plutonia profile, but I am loading PL2.WAD and PL2.deh separately, but I still get Plutonia's story texts when I finish a map that gives you a story text. I then tried to load the zip file, as you did, and it still didn't replace Plutonia 2's story texts. Looking at the Plutonia 2 Dehacked file, the text strings were written in regular caps as opposed to all caps. Could that cause a problem?

#2 Updated by danij over 12 years ago

Evidently I had forgotten the story in Plutonia as Vermil pointed out, the one I am seeing when loading pl2.zip is in fact the original story and not that from Plutonia 2.

#3 Updated by danij over 12 years ago

Fixed for 1.9.0-beta6.8

#4 Updated by danij over 12 years ago

How about this as a solution:

Add new strings using Value definitions (to e.g., jDoom.pk3/values.ded) that contain the names of the Materials that are used for these backgrounds in the IWADs.

Enhance dpDehRead to update these Values if found in a DEH patch.

Extend the Flat <flat-name> InFine command so that a Value Id can be used instead of a flat-name (look for a Value Id first and fall back to a flat look up).

#5 Updated by danij over 12 years ago

I've just tried this myself and it appears to be working fine for me.

Ensure you are loading pl2.zip with the Plutonia profile in Snowberry

Also available in: Atom PDF