Project

General

Profile

Bug #817

hexen crashes after choosing character

Added by eunbolt over 12 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2009-11-14
% Done:

100%


Description

using latest git hexen crashes after choosing character
gdb backtrace pointed at P_LoadACScripts()

gdb trace
http://pastebin.com/m2d17876f

Labels: jHexen

History

#1 Updated by skyjake over 12 years ago

The issue with the Random class menu item is now fixed, but I can't reproduce any P_LoadACSScripts() related issues.

Try recompiling/reinstalling?

#2 Updated by eunbolt over 12 years ago

I still get the crash

#3 Updated by danij over 12 years ago

In case you weren't aware skyjake, KuriKai is compiling and running a 64bit build. In which case, I would suspect the script read routine as being the problem as it looks like it is using the struct acsheader_t for byte offsets and the members thereof are native types (should also be packed).

#4 Updated by danij over 12 years ago

After spending time with KuriKai debugging this via proxy we have narrowed the problem down somewhat.

This crash and the crash on startup when playing jHexen mentioned in the following report seem to stem from the same issue:
http://sourceforge.net/tracker/?func=detail&aid=2220553&group_id=74815&atid=542099

Clearly there is some optimization that gcc is attempting that doesn't suit our code. I have elevated the priority of the other report because it would appear that the same optimization is now applied when using the default $CFLAGS (i.e., a "Release" build).

I suspect that this is similar to the problem skyjake fixed with the random class selection in jHexen.

#6 Updated by skyjake over 12 years ago

I get a crash immediately when selecting the "Random" character in the menu.

Also available in: Atom PDF