Project

General

Profile

Bug #809

[Doom2] Linedef action #30 raises floor too high

Added by siliconwolf over 12 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2009-10-26
% Done:

100%


Description

Linedef action #30 is the one that raises a sector's floor by a certain amount, for example to create a popup switch. In 1.9.0 beta 6.7 it raises the floor level by double the expected amount.

Doom2 MAP17 has a good example, in the western area behind the blue key door. See attached screenshot.

Labels: jDoom

History

#1 Updated by danij over 12 years ago

This is caused by the classic DOOM bug in that texture 0 is treated as a valid texture during texture height look up in vanilla DOOM's EV_DoFloor (which results in reference to the AASHITTY texture).

As the tagged sector has two-sided linedefs with no back material on their bottom section, to preserve DOOM.exe behaviour the material height of the AASHITTY texture should be used instead.

#2 Updated by danij over 12 years ago

Fixed for 1.9.0-beta6.8

#3 Updated by siliconwolf over 12 years ago

screenshot of a switch in MAP17 raised too far

Attachments:

Also available in: Atom PDF