Project

General

Profile

Bug #807

Saved games non-functional in 64bit builds

Added by duclare over 12 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
2009-10-15
% Done:

100%


Description

First I thought that my savegames were corrupted as I would always fall off (or so I think, based on what it looks like) the map immediately after loading a saved game. This happened multiple times, but not always. Now I can easily reproduce a situation where I don't fall of the map, but a lot of objects do (or maybe they just disappear, if it's another unrelated bug), making it impossible to continue.

Start a new game in Shores of Hell. Save immediately. Load. Start playing. The first group of enemies is there, but as soon as you proceed to the next room, you should notice that there are very few opponents. No shotgun on the red thing in the room after the first portal. Oh, and no keys, except the red one in the secret area. Oh, and after going through the first portal, all portals stop functioning. Can't go anywhere, can't get keys. The only way to finish each episode is by paying in one sitting without dying & reloading at any point.

64bit Gentoo, deng-1.9.0_beta6.7. The problem was present in beta 6.2 also; other versions I have not tried.

Labels: Data

History

#2 Updated by danij over 12 years ago

Saved games do not work currently in 64bit builds (which I assume you are using). This problem and will be addressed when the new saved game system is implemented in 1.9.0-beta7

#3 Updated by duclare over 12 years ago

Right, that's a known problem then.

Do you know if anybody is distributing 32bit binaries for Linux? I don't feel like setting up a chroot for this.

#4 Updated by danij over 12 years ago

Have you tried here: http://dengine.net/dew/index.php?title=Installation_(Unix)

Other than that I don't know where you might find one.

Also available in: Atom PDF