Project

General

Profile

Bug #783

Heretic crash & slowdown (possibly related to melee)

Added by roffalcopter almost 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
2009-09-20
% Done:

100%


Description

Two cases in which this happened:
On the level before The Cathedral, on Episode 1, I took my time on that level to kill as many enemies and explore as much of the map as possible, and then I'm not really sure what I was doing, but I think I was using those iron fists that shoot green lightning (which I'm gonna refer to as gloves for now), to kill some gargoyles and golems. Then all of a sudden I get a windows runtime error it seemed. It looked different than the usual doomsday generated error message box, but it kind of had more info than the usual 0xhhhhhhhh write error blah blah windows usually spews up. I forgot to take a screenshot but if it happens again I surely will.
After I restarted doomsday and got past that level, I was in Cathedral, and again, I used the gloves to kill some gargoyles, and then I got a massive slowdown on the game that lasted for about a second. That's what made me think that the gloves gave the error before.
I'm not sure if meleeing and/or gargoyles has anything to do with this, if I get to recreate this crash I'll try to take printscreen of the error and try to upload to this report.
PS. there was nothing on the error on doomsday.out log, that's what made me think it was a windows runtime error rather than a doomsday generated error box.

Labels: Gameplay

History

#1 Updated by danij almost 13 years ago

Thanks for the new information.

Can you enable the highest level of verbose log messages (under settings>developer in Snowberry) then start a game of jHeretic. When you get to the title screen, start a new game (any episode) and when the map appears exit Doomsday. Now locate doomsday.out and attach a copy of it to this bug report.

#3 Updated by roffalcopter almost 13 years ago

Today I got new information. Not only I got it to happen again and took a screenshot of it, but I also got it to happen on Doom too.
I'll attach the screen here (the log is there too but it is the one I added not long ago, I didn't use highest level verbose this time when it happened). BTW, it's the regular violation error box there, guess you'll see it's pretty obvious but just in case if foreign language = too annoying.

#5 Updated by danij almost 13 years ago

This evening I decided to investigate this problem further. Turns out that the error being reported is from a child process spawned by SDL_mixer and the exception indicated actually occurs in winmm.dll

I don't think there is much we can do about this to be honest as it is pretty much outside of our control. However, after further reading the SDL_mixer docs I have noticed a couple of issues with the way in which Doomsday is interfacing with SDL_mixer so I plan to make a couple of changes for 1.9.0-beta6.7 So do let us know once you've had a chance to play around with it whether the problem is resolved.

As for the "slowdown" I would hazard a guess that was most likely due to Doomsday loading resources for the gauntlets, as these are not currently precached.

#6 Updated by roffalcopter almost 13 years ago

Does Default on the sound options use SDL_mixer?

#7 Updated by danij almost 13 years ago

Yes, the "Default" setting for sound driver under Snowberry instructs Doomsday to use SDL_mixer for both sound effects and music.

#8 Updated by roffalcopter almost 13 years ago

Hello, it appears that the issue wasn't resolved because I just got this to happen again.

#9 Updated by danij almost 13 years ago

I didn't really expect the changes I made to make a difference to be quite honest. This is pretty much outside of our control.

One thing you could try:
If you are using a multi-core CPU, try forcing the Doomsday process affinity to a single core.

#10 Updated by roffalcopter over 10 years ago

OK, I got it to happen again. It said something about MCI but I don't quite remember and again, I forgot to take a screenshot. It happened on E1M8, I warped there, got to the part with the golems that shoot yellow skulls and the floating balls that are the barrels of heretic, I blew up some of those balls, hit the switch on the far end of the room and ran back to the start, then I began shooting the golems from there and then the game crashed.

Also available in: Atom PDF