Project

General

Profile

Bug #774

General: Mobjs overlapping more than one sector

Added by vermil almost 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2009-09-10
% Done:

100%


Description

In Beta6.6 on the Dragon Chapel in HeXen, the candles above the slime pool at the back of the main hall fall to the floor when the slime pool they are above lowers.

This is caused by Dday not knowing what sector the candles are considered in, an issue that could occur in the original engine. However in the original engine and Dday 1.8.6, these candles were considered sufficiently in one sector so as not to be affected by this "bug".

Labels: Gameplay

History

#1 Updated by danij over 12 years ago

You are mostly correct however the candles are falling to the height of the ceiling in the sector bellow the wall they are hooked on (mobj_t->ceilingZ is set so on the next tic, P_MobjMoveZ is moving them within that range). For some reason though, it either isn't being triggered in this particular situation with the candles in the original game.

This one is going to be tricky to resolve.

#2 Updated by danij over 12 years ago

Fixed for 1.9.0-Beta6.9

Also available in: Atom PDF