Project

General

Profile

Bug #772

HeXen: Poly object clipping

Added by vermil almost 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
2009-09-09
% Done:

100%


Description

In Beta6.6, it is possible to clip inside moving poly objects under certain circumstances. The player then becomes stuck inside the poly object.

I'll admit that I haven't yet worked out the exact circumstances, but one time it always happens is the moving wall in the left most room in the Guardian of Fire.

The wall moves out as the player walks around the north side of the lava pool.

Labels: jHexen Gameplay

History

#1 Updated by danij over 12 years ago

I've determined an easily reproducible test case:

Put a break point at po_man.c #571 (thrustMobj). Now warp to Hexen::MAP04 (Guardian of Fire). Head to x -530 y 910. You should be stood in front of the sliding wall that will attempt to push you off the ledge into the lava pit.

First attempt:
Take a baby step out in front of the pushing wall. The break point should be hit.

Second attempt:
Hold forward and attempt to run across the face of the pushing wall. The break point will NOT be hit.

Clearly something is going very wrong indeed. Now to figure out the cause...

#2 Updated by danij over 12 years ago

Fixed: Clipping issues with mobj vs T_MovePoly-type polyobjects (e.g., the pushing wall trap in Guardian Of Fire).

There are still issues with T_RotatePoly-type polyobjects. Currently I'm inclined to think they are merely another symptom of the broken wall sliding algorithm.

#3 Updated by danij over 12 years ago

All issues with polyobj vs mobj collision detection now appear to be fixed for 1.9.0-Beta6.9

Also available in: Atom PDF