Project

General

Profile

Bug #770

HeXen: Herisarch's mana cubes

Added by vermil almost 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2009-09-09
% Done:

100%


Description

In Beta6.6, the Heresiarch’s mana cubes randomly disappear and re-appear, either individually or all at once.

Apologies for the vague description, but I could see any obvious pattern to their disappearing/reappearing.

Labels: Graphics

History

#1 Updated by danij almost 13 years ago

I've done some investigation into this problem and it appears this is merely a symptom of larger problem which as yet I've been unable to resolve.

How to recreate:
Start jHexen, MAP01
Open the console and enter:
spawnmobj SORCBOSS -2867 -552 floor; god; makecam 0;
move the player to open area in the south west corner of the map where the polyobjects are in the archived map. In this area should now be Heresiarch.

Now, position the player between the Heresiarch and either the north>south or south>north linedefs on the east or west of this area. You should notice that depending on where the player is in this area and the view angle difference between this linedefs will determine whether the mana cubes are visible or not.

The mana cubes are being clipped as a result of drawing the linedef behind the camera C_AddViewRelSeg in rend_main.c: Rend_RenderSubsector

This would indicate that the test in Rend_MarkSegsFacingFront is determining incorrectly that the segs of this linedef are front facing.

#2 Updated by danij over 12 years ago

I was incorrect in my earlier comment, it is not the segs of the linedef behind the viewer causing these sprites to be clipped. The problem appears to be caused by the ranges added for segs either in the same subsector or further up the BSP tree.

#3 Updated by danij over 12 years ago

The reason why only the cubes are occluded yet the spinning balls are not continues to allude me.

#4 Updated by danij over 12 years ago

The reason the cubes are occluded but the spinning balls and the Heresiarch itself are not is because they are in fact linked to entirely different subsectors!

#5 Updated by danij over 12 years ago

Fixed for 1.9.0-beta6.8

The problem was that after spawning the cubes their position was never again set. Therefore they were still linked to the sector in which they had spawned.

I'm currently looking for any other instances of a similar nature...

#6 Updated by vermil over 12 years ago

I meant "couldn't" instead of "could" above.

Also available in: Atom PDF