Project

General

Profile

Bug #763

Segmenation Violation in Guardian of Fire (MAP04)

Added by xxmiltenxx almost 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2009-09-08
% Done:

100%


Description

I get a Segmentation violation in Hexen MAP04 (Guardian of Fire) after crossing a certain line, after you entered the map with the portal in MAP03 (Guardian of Ice).

Here's a screenshot of the position:
http://img44.imageshack.us/img44/2421/doomsday200909060948230.jpg

If you walk along the wall you'll pass a line and a wall will come out and tries to push you down (it may happen that you'll stand in the wall, due to that clipping errors I think).
After that the bridge will come up and you can access the switch in the middle.

I tested it again a bit and found out that the crash seems to happen after activating the switch in the middle..., but it doesn't occur always.

My way to reproduce the bug:
Go to that line which will cause that the bridge comes up and the wall tries to push you down, but make a step back, so that you woudn't be glitched into it.
Then jump over to the switch, wait until you can activate it and jump over the bridge and shoot the afrits.

Then I'll get that segmentation violation (tested 4 times, 3 times I got the seg. viol.)

The complete Doomsday Out is attached.
I think it's weird to see that he tries to open the
Dir_ChDir: Succeeded: C:\Users\Jan Reimer\Documents\Doomsday Frontend\runtime\
folder directly before the crash, but it might be not related.

Labels: jHexen

History

#2 Updated by danij almost 13 years ago

This is caused by a problem in the node builder. In current release versions, the node builder will produce a degenerate subsector (no segs) in this area and the crash is caused by trying to link the player mobj into it.

I have already addressed this problem in the beta6-with-mapcache branch but the number of changes are to great to back port to the beta6 branch.

Also available in: Atom PDF