Project

General

Profile

Bug #761

Switch doesn't open up before Caves of Circe

Added by roffalcopter almost 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
2009-09-07
% Done:

100%


Description

So, I was doing my mage playthrough which I started after getting my fighter one corrupted, and when I got to that big cave before Caves of Circe, where the entire place collapses, pillars start crushing and huge pits form, I tried heading through the left ledge as always, to reach the switch to recover the floor and remove the pits. However, I was unable to find it. Looking on the map, I could get to it, and I even saw where it should be, a wall with two seams on the texture denoting what seems to be the blocks on the wall that would move up & down revealing the switch. But it didn't open up for some reason. I was playing on the hardest difficulty if the enemies spawned there make any difference (i.e. bog the moving floor script down?).
I died quite a few times on that part, and whenever I could get to there, the switch wasn't there and I assumed it was further away (thus I fell many times on one of the harder jumps and had to restart it all over).

Labels: jHexen Gameplay

History

#1 Updated by danij almost 13 years ago

The area in question is: Shadow Wood (setmap 7) near x:642 y:683

There is a sand coloured stair case in one corner of the cave, walk up it to begin a script which starts a scripted movement of the floors and ceilings in the cave behind you.

It would seem that the problem is due to the interruption of plane movement by mobjs in the cave. Although they are crushed as expected, a plane does not continue its movement after. Resulting in a somewhat random result as to whether this switch can then be reached by normal means.

#2 Updated by danij over 12 years ago

On investigation the only difference I could detect in the behaviour of this scripted sequence (compared to the original game) was the amount of damage dealt by the moving ceilings.

After fixing the amount of dealt damage, this area seems to work as reliably as the original game.

However, the scripts used for this particular trap depend on rather unreliable behaviour and as a player - you may still encounter the inaccessible switch problem.

As an experiment, next time you play through; save your game before entering this area but then instead of going for the staircase first, pull the switch then go to the staircase. The formation of the cave will be considerably different this time.

Fixed for 1.9.0-Beta6.9

Also available in: Atom PDF