Project

General

Profile

Bug #756

Shoots after loading a saved game with a click

Added by roffalcopter almost 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
-
Target version:
Start date:
2009-09-02
% Done:

100%


Description

When I save or load a game, if I confirm my save/load with a click, then after the game is loaded/menu goes away after save, then I'll shoot my weapon once. So far I only did it with the Fighter but when I use weapons that shoot projectiles and always use mana then it could waste some mana. That's kinda annoying because I mostly use the mouse & WASD+around keys to play, and it's kind of annoying to move one of the hands to the Enter key to save/load, but it's no big deal.

Labels: Controllers

History

#1 Updated by skyjake almost 13 years ago

When loading a game, I can't reproduce this. However, when saving, it will fire the weapon if the fire button is used in the menu. Investigating...

#2 Updated by danij over 12 years ago

Looks to me like we need to reinstate logic I had in the original bind context implementation. See here:
engine/portable/src/b_main.c #1447 - queEventsForHeldControls()

I've set the priority for this so high because it really does make controlling the game a problem and prevents using the binding contexts effectively.

#3 Updated by skyjake over 12 years ago

Fixed for beta6.9.

There already was a mechanism that kept track which binding context each individual input device (a particular key/axis/hat) was associated with. However, when this association changes, the old mechanism did not react in any way. Now I've added a logic wherein the state of a particular device key/axis/hat is flagged as "expired" when the context association changes while the device is not in its default state.

In practice, we consider the state of a device unknown when it changes its binding context until we can be sure that it has really returned to its default state.

Also available in: Atom PDF