Project

General

Profile

Bug #754

Gun-Triggered Switches Inactive in PWADs

Added by sonicdoommario almost 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2009-09-02
% Done:

100%


Description

With the release of beta 6.6, switches that are activated by gunfire no longer seem to work in PWADs. I have tried this out in Alien Vendetta and my own WAD, and shooting a switch is activated by gunfire no longer works. This problem was never experienced in past beta versions. However, in IWADs (Doom II Map18 for example), switches that need gunfire work completely fine.

Labels: Gameplay

History

#1 Updated by sonicdoommario almost 13 years ago

Alrighty:

Alien Vendetta
Map06:
X: 371.042
Y: 4594.66
Z: 32

You should be facing northeast (on unrotated automap) at a window and two pillars. The pillar on the left has a shootable switch. Shooting this switch is supposed to open a hidden door to your right.

Now, I don't know why the Doom II Map18 switch worked. Maybe because the switch was on the same door it opened?

#2 Updated by danij almost 13 years ago

Fixed for 1.9.0-beta6.7

#3 Updated by danij almost 10 years ago

Can you give me an example of a switch in map which suffers this problem:

load up Alien Vendetta
warp to a map with the problem
locate a problem switch then with the switch in view
open the console and enter the command "where"
update this tracker item with the following info:

Mod name/download url (e.g., Alien Vendetta)
Map id (e.g., MAP03)
Position (e.g., X423, Y1320)

Also available in: Atom PDF