Project

General

Profile

Bug #751

Getting stuck behind moved surfaces after reloading level

Added by roffalcopter almost 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
2009-08-31
% Done:

100%


Description

Here's how it goes: say you break some windows (I'm not sure how it works on this game, but on some other games I've seen actually the window is moved away and gibs are created when you break them), or you open up some one-way door or something, say Korax wall at the start of the Seven Portals, now those two were two different issues for me but they seem like they could have the same cause. For the windows broken, I saved after breaking them on Bright Crucible, and after I reloaded (after dying ): ), they still looked broken, however they were still blocking my way. One of them I could break again by punching it (it looked like glass gibs came out of nowhere), the other didn't suffer any effect from my fists, it was like I was punching the air, but I couldn't go through the (seemingly) broken window.
For the Korax wall thing, I beat Bright Crucible, and when I came back to the Seven Portals, I was once again inside the starting room, this time with the Korax door gone obviously. However, I couldn't get past it because it was still blocking my way, so I couldn't get out. I'm guessing I can't get back in either after I visit the other sublevels since I'm guessing the door gets reset but doesn't quite move away again when you get back to Seven Portals.

Labels: jHexen Gameplay

History

#1 Updated by danij almost 13 years ago

I can confirm this same issues occurs with pretty much every twosided linedef that changes blocking status dynamically. Most likely a save game problem.

Also available in: Atom PDF