Project

General

Profile

Bug #745

[Render hack] Deep water tricks not supported

Added by sonicdoommario almost 13 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Vanilla emulation
Target version:
Start date:
2009-08-08
% Done:

100%


Description

In Alien Vendetta, there are two levels where you see a slime pool/water that the player "falls" into, even though the slime/water appears to be at the same floor height, but appears at the same floor height due to its surrounded unclosed sectors, which is a little "hack".

However, Doomsday 1.8.6 did not support these either after testing it out on that version (this is found near the Red Key in Map01 of AV, and in a room with Green Armor beyond the Super Shotgun in Map11). Would allowing this screw up the engine or cause an incompatibility or something?

Attached are two images of what the problem is.

Labels: Render hack


Related issues

Related to Feature #1603: Support for id Tech 1 map hacksProgressed2003-07-17

Related to Bug #2254: [Render hack] TNT map02: Deep Water not supportedClosed2017-07-01

History

#3 Updated by danij almost 13 years ago

This DOOM.exe rendering trick can indeed be supported in Doomsday. It is on my shortlist of tricks that will be addressed before 2.0

#4 Updated by danij almost 10 years ago

- labels: Graphics --> Render hack
- summary: "Pool Hack" Unsupported --> [Render hack] Deep water tricks not supported

#5 Updated by danij almost 9 years ago

Fixed for the upcoming 1.12 release.

#6 Updated by danij almost 9 years ago

- status: open --> fixed
- assigned_to: Daniel Swanson
- Milestone: v1.9.0-beta6 --> v1.12

#7 Updated by skyjake over 8 years ago

  • Category set to Vanilla emulation

#8 Updated by skyjake over 2 years ago

  • Related to Bug #2254: [Render hack] TNT map02: Deep Water not supported added

Also available in: Atom PDF