Project

General

Profile

Bug #737

Dehacked Files Crash Doomsday

Added by sonicdoommario almost 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2009-07-31
% Done:

100%


Description

Although the Dehacked files were fixed in beta 6.4, loading a Dehacked file now seems to crash Doomsday. I loaded AV.DEH, and it caused Doomsday to crash.

Z_Create: New 32.0 MB memory volume.
Con_Init: Initializing the console.
Executable: Version 1.9.0-beta6.5 Jul 31 2009 (DGL).
Sys_InitWindowManager: Using Win32 window management.
Z_Create: New 32.0 MB memory volume.
createContext: OpenGL.
OpenGL information:
Vendor: ATI Technologies Inc.
Renderer: RADEON X700 Series
Version: 2.1.8543 Release
GLU Version: 1.2.2.0 Microsoft Corporation
Available Texture units: 8
Maximum Texture Size: 2048
Maximum Anisotropy: 16
Num Texture Formats: 0
Line Width Granularity: 0.2
Line Width Range: 1.0...63.0
Extensions:
GL_AMD_performance_monitor GL_ARB_depth_texture
GL_ARB_draw_buffers GL_ARB_fragment_program
GL_ARB_fragment_program_shadow GL_ARB_fragment_shader
GL_ARB_framebuffer_object GL_ARB_half_float_pixel
GL_ARB_half_float_vertex GL_ARB_map_buffer_range
GL_ARB_multisample GL_ARB_multitexture
GL_ARB_occlusion_query GL_ARB_pixel_buffer_object
GL_ARB_point_parameters GL_ARB_point_sprite
GL_ARB_shader_objects GL_ARB_shading_language_100
GL_ARB_shadow GL_ARB_shadow_ambient
GL_ARB_texture_border_clamp GL_ARB_texture_compression
GL_ARB_texture_cube_map GL_ARB_texture_env_add
GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar
GL_ARB_texture_env_dot3 GL_ARB_texture_float
GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_tw
GL_ARB_texture_rectangle GL_ARB_transpose_matrix
GL_ARB_vertex_array_object GL_ARB_vertex_buffer_object
GL_ARB_vertex_program GL_ARB_vertex_shader
GL_ARB_window_pos GL_ATI_draw_buffers
GL_ATI_envmap_bumpmap GL_ATI_fragment_shader
GL_ATI_meminfo GL_ATI_separate_stencil
GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3
GL_ATI_texture_float GL_EXT_abgr
GL_EXT_bgra GL_EXT_blend_color
GL_EXT_blend_equation_separate GL_EXT_blend_func_separate
GL_EXT_blend_minmax GL_EXT_blend_subtract
GL_EXT_compiled_vertex_array GL_EXT_copy_texture
GL_EXT_draw_range_elements GL_EXT_fog_coord
GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample
GL_EXT_framebuffer_object GL_EXT_gpu_program_parameters
GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil
GL_EXT_packed_pixels GL_EXT_point_parameters
GL_EXT_rescale_normal GL_EXT_secondary_color
GL_EXT_separate_specular_color GL_EXT_shadow_funcs
GL_EXT_stencil_wrap GL_EXT_subtexture
GL_EXT_texgen_reflection GL_EXT_texture3D
GL_EXT_texture_compression_s3t GL_EXT_texture_cube_map
GL_EXT_texture_edge_clamp GL_EXT_texture_env_add
GL_EXT_texture_env_combine GL_EXT_texture_env_dot3
GL_EXT_texture_filter_anisotro GL_EXT_texture_lod_bias
GL_EXT_texture_mirror_clamp GL_EXT_texture_object
GL_EXT_texture_rectangle GL_EXT_texture_sRGB
GL_EXT_texture_swizzle GL_EXT_vertex_array
GL_KTX_buffer_region GL_NV_blend_square
GL_NV_texgen_reflection GL_SGIS_generate_mipmap
GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod
GL_WIN_swap_hint WGL_EXT_swap_control
Extensions (WGL):
WGL_ARB_extensions_string WGL_ARB_pixel_format
WGL_ATI_pixel_format_float WGL_ARB_pixel_format_float
WGL_ARB_multisample WGL_EXT_swap_control
WGL_ARB_pbuffer WGL_ARB_render_texture
WGL_ARB_make_current_read WGL_EXT_extensions_string
WGL_ARB_buffer_region WGL_EXT_framebuffer_sRGB
WGL_ATI_render_texture_rectang WGL_EXT_pixel_format_packed_fl
WGL_I3D_genlock WGL_NV_swap_group
WGL_ARB_create_context WGL_AMDX_gpu_association
DGL Configuration:
NPOT Textures: Disabled
Texture Compression: Disabled
Variable Texture Anisotropy: Enabled
Utilized Texture Units: 2
Multisampling: Enabled (20)
createContext: OpenGL.
GL_Init: Initializing Doomsday Graphics Library.
Multitexturing enabled (full).
Sys_Init: Setting up machine state.
Sys_Init: Initializing keyboard, mouse and joystick.
Sys_InitTimer.
Sys_InitMixer: C-Media Rear Panel Audio
Driver: SDLMixer
Sfx_Init: Initializing...
Sfx_InitChannels: 16 channels.
S_Init: OK.
Parsing configuration files.
W_Init: Init WADfiles.
W_AddFile: C:\Program Files\Doomsday\data\doomsday.pk3
W_AddFile: C:\Program Files\Doomsday\data\jdoom\jdoom.pk3
W_AddFile: C:\Documents and Settings\Administrator\My Documents\Timmy's Files and Documents\Doom\DOOM2.WAD
IWAD identification: 00f36acb
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb032.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb033.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb034.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb035.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb036.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb037.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb038.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb039.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb040.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb041.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb042.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb043.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb044.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb045.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb046.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb047.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb048.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb049.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb050.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb051.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb052.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb053.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb054.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb055.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb056.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb057.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb058.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb059.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb060.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb061.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb062.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb063.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb064.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb065.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb066.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb067.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb068.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb069.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb070.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb071.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb072.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb073.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb074.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb075.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb076.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb077.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb078.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb079.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb080.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb081.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb082.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb083.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb084.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb085.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb086.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb087.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb088.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb089.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\fontb090.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\m_therm2.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\mapmask.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\menufog.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\pal18to8.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\sndcurve.lmp
W_AddFile: C:\Program Files\Doomsday\data\jdoom\auto\.basedata\stcfn032.lmp
W_AddFile: ERROR: C:\Program Files\Doomsday not found!
W_AddFile: ERROR: C:\Program Files\Doomsday\snowberry\runtime not found!
W_AddFile: C:\Documents and Settings\Administrator\My Documents\Timmy's Files and Documents\Doom\AV.DEH
W_AddFile: C:\Documents and Settings\Administrator\My Documents\Timmy's Files and Documents\Doom\AV.WAD
W_AddFile: ERROR: 16 not found!
W_AddFile: ERROR: 1280 not found!
W_AddFile: ERROR: 1024 not found!
W_AddFile: ERROR: jDoom.dll not found!
W_AddFile: ERROR: 32 not found!
W_AddFile: ERROR: C:\Program Files\Doomsday not found!
W_AddFile: ERROR: C:\Program Files\Doomsday\snowberry\runtime not found!
W_AddFile: ERROR: 16 not found!
W_AddFile: ERROR: 1280 not found!
W_AddFile: ERROR: 1024 not found!
W_AddFile: ERROR: jDoom.dll not found!
W_AddFile: ERROR: 32 not found!
Reading definition file: C:\Program Files\Doomsday\defs\doomsday.ded
Reading definition file: C:\Program Files\Doomsday\defs\jdoom\jdoom.ded
Reading definition file: C:\Program Files\Doomsday
Reading definition file: C:\Program Files\Doomsday\snowberry\runtime
Reading definition file: C:\Documents and Settings\Administrator\My Documents\Timmy's Files and Documents\Doom\AV.DEH
Def_ReadDEDFile: Error in C:\Documents and Settings\Administrator\My Documents\Timmy's Files and Documents\Doom\AV.DEH:
Line 253: Unexpected end of file.

Labels: Data

History

#1 Updated by danij almost 13 years ago

Looks to me like Doomsday is trying to load AV.DEH as a DED file. Please ensure you are loading it using the -deh command and not -def.

#2 Updated by skyjake almost 13 years ago

Definitely something wrong the arguments, look at all the stuff it tries to load with W_AddFile.

Would be nice to see Snowberry's response file that it uses to launch Doomsday (the "options.rsp" file).

#3 Updated by danij almost 13 years ago

Good point. It could be a new issue in Snowberry as a result of updating to Python 2.6

#4 Updated by sonicdoommario almost 13 years ago

Here is the options.rsp file:

-basedir "C:\Program Files\Doomsday" -userdir "C:\Program Files\Doomsday\snowberry\runtime" -file "C:\Documents and Settings\Administrator\My Documents\Timmy's Files and Documents\Doom\timmy.wad" -sfxchan 16 -texcomp -wh 1280 1024 -game jDoom.dll -iwad "C:\Documents and Settings\Administrator\My Documents\Timmy's Files and Documents\Doom\DOOM2.WAD" -bpp 32

#5 Updated by danij almost 13 years ago

I have just tried the repackaged 1.9.0-beta6.5 windows released this morning, loading av.zip (Alien Vendetta) and everything seems to be working fine for me, the DEH patch is being applied correctly.

#6 Updated by danij almost 13 years ago

Its looking to me like something is going wrong with the -file command line option.

#7 Updated by sonicdoommario almost 13 years ago

Even after uninstalling and then reinstalling the repackaged Doomsday, I still get the crashes.

I also tried deleting options.rsp and then re-launching, but it still caused Doomsday to crash.

-basedir "C:\Program Files\Doomsday" -userdir "C:\Program Files\Doomsday\snowberry\runtime" -file "C:\Documents and Settings\Administrator\My Documents\Timmy's Files and Documents\Doom\AV.WAD" -deh "C:\Documents and Settings\Administrator\My Documents\Timmy's Files and Documents\Doom\AV.DEH" -sfxchan 16 -texcomp -wh 1280 1024 -game jDoom.dll -iwad "C:\Documents and Settings\Administrator\My Documents\Timmy's Files and Documents\Doom\DOOM2.WAD" -bpp 32

#8 Updated by danij almost 13 years ago

Although the DEH patch is being applied correctly on my system and I do not get a crash I can confirm similar behavior to that reported here. It seems to be a problem in Doomsday.

Once I get myself oriented to the Git working environment I will look into this issue.

#9 Updated by skyjake almost 13 years ago

This may be now resolved as the issue with -file/-def options (evident in the startup messages above) has been fixed for Beta 6.6.

#10 Updated by danij almost 13 years ago

I'm going to assume that this problem is now resolved as the submitter has since shown that they can play this mod in 1.9.0-beta6.6

Also available in: Atom PDF