Project

General

Profile

Bug #735

[ATI] OpenGL crash upon starting map (Catalyst AI)

Added by codone almost 13 years ago. Updated almost 10 years ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
-
Target version:
Start date:
2009-07-28
% Done:

0%


Description

In the "ATI Catalyst Control Center" (this is the ATI driver settings), there is an option for disabling the "Catalyst AI". This setting is some type of Anti-aliasing setting. I normally have this setting Enabled in "advanced" mode (there is a standard mode as well). With this setting Enabled, the Doomsday engine (in OpenGL mode) crashes when loading the map (E1M1) for heretic (see both logs below, one with setting Enabled which causes crash, one log with setting Disabled which runs okay). For the record, I tried Doomsday Engine Beta 4, and selected DirectX instead of OpenGL, and it worked with this setting Enabled. 1.9.0 Beta 6, I did not see how to use DirectX, and therefore was crashing until I found to disable this "Catalyst AI" mode in the ATI driver. I will go ahead and attach the complete OUT file from the crash. Here are some specs on my PC.

----------------
Graphics card: ATI 4870 512Mb GDDR5 RAM

Driver Packaging Version 8.60-090316a1-078234C-ATI
Catalystâ„¢ Version 09.4
Provider ATI Technologies Inc.
2D Driver Version 6.14.10.6936
2D Driver File Path System/CurrentControlSet/Control/Video/{F1291161-BD9E-4042-B516-43B5F85E58AC}/0000
Direct3D Version 6.14.10.0655
OpenGL Version 6.14.10.8577
Catalystâ„¢ Control Center Version 2009.0428.2132.36839
AIW/VIVO WDM Driver Version 6.14.10.6238
AIW/VIVO WDM SP Driver Version 6.14.10.6238
-----------------
CPU Intel Quad core 3.0gzh

-----
Here is the Doomsday Engine OUT log with Catalyst AI set to Disabled (THIS WORKS -- NO CRASH!)
---------
R_InitModels: Done in 1.52 seconds.
TGA_Load32_rgba8888: I don't know this format!
(type=1 pxsize=8 abits=8)
P_LoadMap: "E1M1"
convertMap: Attempting conversion of "E1M1".
WadMapConverter::Convert: Attempting map conversion...
WadMapConverter::Convert: DOOM map format.
BSP_Build: Built 384 Nodes, 385 Subsectors, 1876 Segs, 908 Vertexes
Balance +1 (l13 - r12).
Build subsector tables...
Build line tables...
convertMap: Successful.
R_InitLinks: Initializing

E1M1: The Docks
Author: Raven Software
-----------------------------
-----
Here is the log with Catalyst AI set to Enabled (Task locks up on LOADING in Progress "circle".. note the "Segmentation Violation" below)
---------
--------------
R_InitModels: Done in 1.84 seconds.
TGA_Load32_rgba8888: I don't know this format!
(type=1 pxsize=8 abits=8)
P_LoadMap: "E1M1"
convertMap: Attempting conversion of "E1M1".
WadMapConverter::Convert: Attempting map conversion...
WadMapConverter::Convert: DOOM map format.
BSP_Build: Built 384 Nodes, 385 Subsectors, 1876 Segs, 908 Vertexes
Balance +1 (l13 - r12).
Build subsector tables...
Build line tables...
convertMap: Successful.
R_InitLinks: Initializing
Segmentation Violation

E1M1: The Docks
Author: Raven Software

Labels: OpenGL Renderer

History

#1 Updated by codone almost 13 years ago

Logfile for crash, with Catalyst AI Enabled in driver

Attachments:

#2 Updated by danij about 12 years ago

Is this issue still present in the latest 1.9.0-Beta6.9 release?

#3 Updated by codone about 12 years ago

As per query from danij, I tried the latest deng-1.9.0-beta6.9. There is no change. I did, however, notice more information about this that I can give. That setting I am referring to, "Catalyst AI", as I said, it has three settings - DISABLED, Standard, and Advanced. It runs fine on DISABLED and STANDARD. It only crashes on ADVANCED. Honestly, this is a minor issue overall since running it on Standard or even Disabled it still looks great. But it could be a symptom of something wrong in the graphics engine, so from that respect, it might be worth looking into. Note, I am running the same (now old) drivers that I was about a year ago when I reported this problem (it's a long story) which is ATI Catalyst 9.4. But these drivers are stable, and no other games, etc, have had a problem with the "advanced" setting. Feel free to contact me further if I can help.

#4 Updated by skyjake almost 10 years ago

- status: pending --> wont-fix

Also available in: Atom PDF