Project

General

Profile

Bug #693

Keybord and mouse controlls delayed

Added by alakayonk about 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
2009-05-26
% Done:

100%


Description

Once game has started (jheretic or jhexen) the controls are delayed. Video is at 100+ fps so I don't think it is video related. Example . I press forward and the response is a half to a full second later. This is for all movement keys, mouse buttons, and while in gameplay the menu selection/navigation keys. This is not for the x/y axis of the mouse. The mouse movement responds as normal.

Labels: Gameplay

History

#1 Updated by danij about 13 years ago

This sounds like this common issue (not a bug in Doomsday):

http://forums.newdoom.com/showthread.php?t=36343

#2 Updated by alakayonk about 13 years ago

Maybe maybe not. First of all I don't have ANY un-necessary process running.
alg.exe
avgtray.exe
mDNSResponder.exe
avgcsrvx.exe
avgwdsvc.exe
explorer.exe
spoolsv.exe
lsass.exe
winlogon.exe
services.exe
csrss.exe
avgnsx.exe
avgrsx.exe
system
system Idle Process
svchost.exe

That is all processes running.
I come to the conclusion that If the only thing that has changed is the version of doomsday
(the delay never occurred in older versions) but my system and it's running processes have not. Then the new version has a problem. Granted I could be wrong. I just don't see what I could do about it. Any suggestions?

#3 Updated by danij about 13 years ago

Newer versions of Doomsday simply "play nicer" with the underlying operating system and by that I mean; Doomsday will forward certain Windows messages that previously, it would not.

The few other reports I have regarding similar issues have all been due to another process on the system that is intercepting messages bound for Doomsday.

Also available in: Atom PDF