Project

General

Profile

Bug #674

Segmentation violation: semi-transparent wall texture (bars)

Added by mittens about 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
2009-04-19
% Done:

100%


Description

Hi,

I have recently been testing a new PWAD that I designed (http://www.starfighter.acornarcade....doom.htm#rienzi) on various different Doom source ports. Doomsday does by far the best job of rendering it, but unfortunately consistently crashes with a segmentation fault at a particular location in the level. By judiciously modifying the WAD file I believe I have identified the cause as semi-transparent wall textures on double-sided linedefs (typically used for bars). This would also explain why Doomsday crashes in the same manner when I turn around 180 degrees at starting position of map 1 of the Doom 2 IWAD. If I remember correctly, there is an outside enclosure with bars behind the player's starting position.

I have attached the verbose doomsday.out log file produced by the game engine in the hope that this might help to diagnose the fault. As you can see, I was using Version 1.9.0-beta6.1 Mar 31 2009 (DGL) of Doomsday with the Doom 2 IWAD and no PWADs, with an Intel Cantiga v2.0.0 (build 7.15.10.1576) as the OpenGL renderer. My machine is a recently-purchased Dell Inspiron 1545-5713 laptop.

I really hope it might be possible to fix this problem because the Doomsday Engine looks amazingly nice!

Labels: jDoom

History

#2 Updated by mittens about 13 years ago

Output from version 1.9.0-beta6.3 Jun 8 2009 (DGL).

Attachments:

#3 Updated by mittens about 13 years ago

I'm sorry to say this problem persists in version 1.9.0-beta6.3 Jun 8 2009 (DGL).

#4 Updated by mittens almost 13 years ago

I can no longer replicate this bug in 1.9.0-beta6.5, so I am marking it as fixed.

Also available in: Atom PDF