Project

General

Profile

Bug #667

HeXenDK Abattoir clipping bug

Added by vermil about 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
2009-04-13
% Done:

100%


Description

In the HeXenDK map Abattoir (map16 to level warp cheats) there is a specific setup that can cause reproducibly cause the player to clip through the wall that has been present for an unknown amount of time in Dday (i.e. both 1.8.6 and Beta6.1 exhibit the bug).

In the large room to the top left of the map (the one full of Reivers), there is a hole with a switch, helmet pickup and Stalker at the bottom. Pressing said switch causes the floor of the hole to raise.

If the player falls/drops down into this hole and presses the switch before they land, without killing the stalker first, they will be thrust partially through the wall behind the switch when they land on top of the Stalker.

If they kill the Stalker first, they are not thrust through the wall if the press the switch before they land at the bottom of the hole.

A bug specific to this area, but one that is quite easy to cause as it is very easy to press the switch before landing in this particular setup (and may actually be tactically beneficial to attempt as if the floor has risen slightly before you hit it, you may take less fall damage) due to there being no z check on whether you can press a switch in the Doom engine.

I have attached a pair of screenshots, one a map shot showing the location of the hole and another of the player looking down the hole (the kill command was invoked before taking the shot, hence why the stalker isn't shown down there).

Labels: jHexen Gameplay

History

#3 Updated by danij almost 13 years ago

This issue should now be fixed as of 1.9.0-beta6.6 but if not, reopen this tracker item and we'll investigate further.

Also available in: Atom PDF