Project

General

Profile

Bug #666

[Hexen] Inefficient "kill" command and massacre cheat

Added by vermil about 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
-
Target version:
Start date:
2009-04-13
% Done:

100%


Description

It seems that in Beta6.1 the kill console command is missing HeXen bad guys that don't have the mf_shootable flag when the command is invoked. This means it misses submerged Stalkers and Reivers that have yet to come out the ground.

1.8.6 will kill non-dormant versions of both these foes when they are in these states.

Also, the kill command has always missed charging Maulotaurs in Heretic (i.e Mauloaturs in mid charge aren't killed by the command).

Labels: jHexen Gameplay

History

#1 Updated by vermil about 11 years ago

Another "issue" with the kill console command and massacre cheats in Heretic and HeXen:

Not a bug as such, more an oversight.

They simply do a large amount of damage to all bad guys with the mf_shootable flag (and Lost Souls), rather than actually killing them. If one has a bad guy with more health (or infinite health) than the command and cheat do, they obviously aren't killed by them, only damaged.

I changed the summary title to indicate that there is more than one issue in this bug report.

#2 Updated by skyjake almost 10 years ago

Improved the "kill" command for 1.9.9 so that swimming Stalkers and buried Wraiths are killed, too.

The Heretic issue needs to be moved to another bug report.

The command still works like before (10000 damage dealt).

Also available in: Atom PDF