Project

General

Profile

Bug #632

jHexen: Savegame Crash with jXRP

Added by xxmiltenxx over 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2009-02-28
% Done:

100%


Description

After using the addon "jXRP" for Hexen I couldn't load a savegame (if I disable that addon I can load that savegame). The game chrashes with the following error message:

P_MapInitPolyobjs: Warning: Multiple polyobjs in a single subsector
(ssec 709, sector 314). Previous polyobj overridden.
P_MapInitPolyobjs: Warning: Multiple polyobjs in a single subsector
(ssec 708, sector 314). Previous polyobj overridden.
P_MapInitPolyobjs: Warning: Multiple polyobjs in a single subsector
(ssec 464, sector 275). Previous polyobj overridden.
P_MapInitPolyobjs: Warning: Multiple polyobjs in a single subsector
(ssec 358, sector 104). Previous polyobj overridden.
P_MapInitPolyobjs: Warning: Multiple polyobjs in a single subsector
(ssec 357, sector 104). Previous polyobj overridden.
P_MapInitPolyobjs: Warning: Multiple polyobjs in a single subsector
(ssec 367, sector 98). Previous polyobj overridden.
Segmentation Violation

Labels: jHexen

History

#1 Updated by danij over 13 years ago

Please attach your savegame files to this tracker item so that we may debug the problem.

#3 Updated by xxmiltenxx over 13 years ago

I've uploaded the "hexndata" and "doomsday.out from "Doomsday\snowberry\runtime", but I had to split the file, because the size was over 256 kb, it's packaged with WinRar.

I've tested it with the first savegame.
File Added: Hexen Savegame.part1.rar

#5 Updated by xxmiltenxx over 13 years ago

File Added: Hexen Savegame.part2.rar

#6 Updated by danij over 13 years ago

This problem does not seem to be related to the save games, the problem seems to originate from the particle generator subsystem. I am able to reproduce the problem but the point at which a sigsegv is thrown is not consistent. More investigation is needed.

If I disable particles ("rend-particle 0") before attempting to load the save game in slot 1, it works just fine.

#7 Updated by xxmiltenxx over 13 years ago

I tested it again, with disabling several parts of the jXRP.
I've encountered, that if I disable "XCCP Decorations" it works. So I took a look into the "Decor-XCCP.pk3" and found out, that if I delete the "Blue_Candle.ded" or "Brasstorch.ded" it works.
You said you were able to run it with disabling particles, so I looked into these DED's.
Under "Generator" in those DED's, the particles (number I think) are set to 333. So I first thougt something like an overflow of particles. But I just changed it to 500 and it works suddenly.
But there's another thing. If I only use "XCCP Decorations" with those particles set to 333, it seems to work (had 1 crash, but 5 times it worked...)
Don't know it that'll help you.

#8 Updated by danij over 13 years ago

Fixed in svn for 1.9.0-beta6.1

Also available in: Atom PDF