Project

General

Profile

Bug #619

Snowberry: Misaligned text in lists

Added by skyjake over 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2009-02-26
% Done:

100%


Description

The profile names are not aligned properly in the profile list. See attached screenshot (beta5.1 on the left, beta6 on the right with the bad alignment).

Labels: Snowberry

History

#2 Updated by skyjake over 13 years ago

Also, the issue is with the settings categories (screenshot 2).

#4 Updated by danij over 13 years ago

I can't be sure from the screenshots alone; is this a Windows-specific issue? Only, I've just tried rebuilding Snowberry but I notice in the build log that I am apparently missing a module called wxStaticText which I presume from the name should have been installed with the wxPython stuff.

#5 Updated by skyjake over 13 years ago

The alignment is correct on the Mac at least.

Also:
  1. import wx
  2. wx.version()
    '2.8.3.0 (mac-unicode)'

#6 Updated by skyjake over 13 years ago

It's odd that it says wxStaticText is missing since the static text is part of the core functionality of wx.

#7 Updated by danij over 13 years ago

wxVersion() is reporting:
2.8.9.2 (ansi)

I tried the unicode package originally but after a bunch of compile errors and a tip off in snowberry/build.bat I switched to the ansi package and build seemed to work fine:

REM -- Additional binary dependencies.
ECHO Copying dependencies to ./dist...
copy "%PYTHON_DIR%"\lib\site-packages\wx-2.8-msw-ansi\wx\msvcp71.dll dist

I'll try building with wxPython 2.8.3.0 unicode

Also available in: Atom PDF