Project

General

Profile

Bug #593

Sky Glow oversights

Added by vermil over 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2009-01-18
% Done:

100%


Description

The attached screenshots do a better job than words could.

Labels: OpenGL Renderer

History

#3 Updated by danij over 13 years ago

Not a bug, this is by design, though, I do agree that the spreading of the sky colour into sectors which do not have sky ceilings/floors does not look right.

#4 Updated by skyjake over 13 years ago

What if the sky color would spread only to sectors whose lighting level is lower than the originating sky sector's? That would somewhat replicate the physical phenomenon of light spreading from the sky to darker areas.

In practice one would probably have to do some interpolation at the threshold to avoid abrupt color changes when a sector's light level gradually changes.

#5 Updated by danij over 13 years ago

That would certainly help. However, the main issue I have with this is not the blending/balancing of the light values, rather the "shape" of the sky light colour depends entirely upon the geometry of the map itself, as it is uniform sector lighting. The result is light that appears to travel around corners, extend much too far (E3M8) or simply look uneven in maps more complex than the relatively basic maps in the IWADs.

Once the light grid is tuned up it should produce pretty good results if used for this. When disabled though, I think it would look better with no spreading at all unless a new algorithm is designed specifically for this.

#6 Updated by danij over 13 years ago

To clarify; by "shape" of the sky I am referring to the shape of the sectors to which the light spreads, not the shape of the sector(s) casting the light.

#7 Updated by vermil over 13 years ago

Well. That's why I titled the report "oversights" rather than "bugs".

That said, for what my opinion is worth, I would agree with Danij that no spreading at tall would be a suitable stopgap until there is the time to plan and implement a new approach (or even a "replacement" if yourselves ultimately decide not to develop a new method).

It may lose a little visual piaz, but would always look professional (i.e there wouldn't be anything unprofessional looking like the effect on E3M8).

#8 Updated by danij over 11 years ago

Upon investigating the mechanics of the current sky colour spread algorithm I decided to remove it entirely. My reasoning:

  • Existing algorithm fundamentally flawed as it assumes a sector is one polygon. Maps which use the same sector id on multiple disjoint subsector groups could be erroneously classified as a dominant light source (often resulting in dramatic changes to lighting from those intended by the map author).
  • Existing algorithm did not respond to surface material changes, so when changing to/from a sky-masked material all neighbouring dominant light sources were not updated.

Also, now that we have the lightgrid (which already factors in the sky colour) I don't think it is necessary to attempt spreading within the uniform sector lighting model. If we do decide to do this the algorithm needs to be cleverer.

Also available in: Atom PDF