Project

General

Profile

Bug #572

IDMUSxx cheat ded oversights

Added by vermil over 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
2008-11-29
% Done:

100%


Description

I'd imagine this is an oversight more than anything else and not a big thing really (especially given Dday's playmusic xxx command).

The IDMUSxx cheat always plays whatever lump the loaded audio def has for the map selected by the cheat. It ignores whether the music for the map has been changed in the loaded map def.

Also, related, the cheat seems to have a hardcoded range still. It can't read beyond the original game's 1-35 track numbers when there is more than 35 maps being loaded (i.e you can't type IDMUS36+) even if there are Maps36+ being loaded).

Labels: Music

History

#1 Updated by danij over 13 years ago

Not a bug. This cheat plays a music track, without any care to what map(s) it might be used on by selecting the music by track number.

The only real limitation here is that (as you noted) the possible track range is hardcoded to limit to 1 ... 35

Also available in: Atom PDF