Project

General

Profile

Bug #521

Small player cross and key required xg bug

Added by vermil about 14 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2008-06-24
% Done:

100%


Description

A small oversight probably.

If you have a player_cross XG line that also requires a key(s) to activate, you'll hear the press wall sound if you walk over it without one or more of the required key(s).

Labels: XG

History

#1 Updated by danij about 14 years ago

Logged In: YES
user_id=849456
Originator: NO

This is by design. All objects that require a key to activate are treated universally in XG so a door that requires a key to open is treated in exactly the same way.

Why would you not want to tell the player when they don't have the required key(s) to activate?

#2 Updated by vermil about 14 years ago

Logged In: YES
user_id=1420350
Originator: YES

You misunderstand. I'm not saying that the player shouldn't be told that they don't have the required key when they try to activate an XG line that requires one (even if it does mean you can't set up walk over XG lines to initiate ambushes and such that only occur once the player does have the key because the message could have already given it away that there is a trigger there).

What I was talking about was that when the player walks over a walk over XG line, that requires a key they don't have, to activate, the press wall sound is also played along with the message being given.

It is surely a little odd having the player sound like they are pressing thin air in this circumstance. Hence why I thought it was a possible oversight.

But what you've written suggest it as intentional. So I guess this bug report has become a feature request/suggestion for Dday to play a different sound in this circumstance (maybe DSRADIO for instance).

#3 Updated by danij about 14 years ago

Logged In: YES
user_id=849456
Originator: NO

I have fixed the issue of the use wall sound being played in this instance, in svn for 1.9.0-beta6.

If you would like the other issue addressed (optional disabling of the "You need object X" message on XG line types which require said object for activation) please submit an RFE.

#4 Updated by vermil about 14 years ago

Logged In: YES
user_id=1420350
Originator: YES

Well, I never made a request to optionally disable the message telling the player they needed object x in my original post. But you've just reminded me of something related, for an RFE.

Also available in: Atom PDF