Project

General

Profile

Bug #495

Unable to change weapons

Added by ratmestic over 14 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
-
Target version:
Start date:
2007-11-29
% Done:

100%


Description

linux, Ubuntu Feisty, a self-compiled 1.9.0beta5.2

Playing the first level of Eternal Doom, I am unable to switch weapons. I mean 1) any weapons I obtain during playing, and 2) any weapons gained by i-d-f-a.

"Show ASCII codes of pressed keys" seems to work. Every key appears in the console, and there is nothing unexpected. I use keypad to move, and keypad produces codes different from the keyboard's numbers.

Setting s for shotgun, f for fists or p for pistol does not work. The "setup controls" menu accepts and saves my choices. But, back in the game, I can press the keys as many times as I want, and nothing happens.

Once what happened was that pressing 3 on keyboard made me slowly move forward, and putting 7 down on the keyboard made my pistol fire after a slight delay. One key made me strafe, and there were actually multiple keys that made me fire, but always after a delay. These changed a bit while I tried them out. I mean, for a while, the game did random things from the numbers on the keyboard. Keypad continued to function as expected. But after a while (a couple of minutes in the 1st level, space station, of Eternal Doom) this stopped, and after that the numbers did nothing.

Back to linux's console, all keys worked as expected. I have a wired keyboard, so this can't be about transmission or battery problems of a wireless kbd.

Labels: Controllers

History

#1 Updated by ratmestic over 14 years ago

Logged In: YES
user_id=1615624
Originator: YES

This has nothing to do with Eternal Doom. I tried plain Doom2, and encountered the same problem.

#2 Updated by danij over 14 years ago

Logged In: YES
user_id=849456
Originator: NO

This issue has been fixed in svn for 1.9.0-beta6

#3 Updated by danij over 14 years ago

Logged In: YES
user_id=849456
Originator: NO

This seems to be a duplicate of #1809223.

Also available in: Atom PDF