Project

General

Profile

Bug #475

Doomsday segfault, TCP dies

Added by brucecampbell almost 15 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
-
Target version:
Start date:
2007-09-30
% Done:

100%


Description

Ive been playing doom with doomsday for several releases and this latest release of 1.9.5 has given me a lot of grief. If I try to join a game with other people, I randomly get kicked out when someone else joins, even with a high player limit.
When I host a game I get a random crash that freezes the game solid and I need to kill it with taskmanager. When I start up a new game I get windows popping up from underneath telling me that my windows shares have disconnected. I think the crash kills TCPIP.. I have to reboot to get it to come back up again. Cant ping anything on the LAN.
Ive also had problems in the past joining games and freezing the second I fire at something. Ive tried this with two modern NAT routers, a netgear and a linksys and both should do UDP tracking ok.

Labels: Multiplayer

History

#2 Updated by docfu almost 15 years ago

Logged In: YES
user_id=1902377
Originator: NO

Hello,

I can confirm this bug, it's very annoying indeed. I don't get the TCP problems but playing doomsday(doom 1 or 2) we get multiple crashes when 3-4+ players start joining. Every one with a segfault. Please let me know if there is anything we can do to help debug this problem. We tried turning off particles as suggested in another thread but that didn't fix it...

Also available in: Atom PDF