Project

General

Profile

Bug #468

End-level time/par time displays broken

Added by atimson almost 15 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2007-08-21
% Done:

100%


Description

In v1.9.0-beta5.1, the user time/par time for a level do not display correctly.

The user time always displays as " :02", unless the user clicks/presses a key so as to cancel the clicking display; in such a case, the correct time is displayed. (The sound of the ticking display is not heard, though it is with kills/items/secrets as it should be.)

With a vanilla game--only using the Ultimate Doom IWAD, and no resource pack elements--the label for the par time is displayed, but no value ever is.

Using the jDoom Resource Pack (jDRP-20070404, jDEP-20060601, jDEP-EXT-20060501, jDTP-base-20060613, jDTP-walls-doom1-20060731, jDUI-20060825), the same bug with the level time occurs; the par label and time are not displayed at all, even though the par time is defined in the IWAD.

The same occurs with the Doom II IWAD, with and without the jDRP material respectively.

My assumption is that this is related to the fix for bug #1548165.

Labels: User Interface

History

#1 Updated by atimson almost 15 years ago

Logged In: YES
user_id=862248
Originator: YES

Could you please tell me which bug this is a duplicate of? I did look, even in the Closed ones, and didn't see it...

#2 Updated by yagisan almost 15 years ago

Logged In: YES
user_id=1248824
Originator: NO

It's this one mate -> https://sourceforge.net/tracker/?func=detail&atid=542099&aid=1548165&group_id=74815

Thank you for taking the time to submit the bug. Please continue to submit any other bugs you encounter.

#3 Updated by atimson almost 15 years ago

Logged In: YES
user_id=862248
Originator: YES

That doesn't look like the same one to me.

The bug you cited is about the fallback if the game can't find the par time; this bug affects the level time, not the par time. It's able to find the level time (unlike the par time in the other bug), it's just not actually displaying it most of the time.

(The frustrating part is that the code in the beta-5.1 tarball for displaying the stats is basically the same as for Linux Doom v1.10; on the other hand, since it's not strictly controlled by WI_DrawStats (it doesn't draw in the order it calls for), I'm obviously missing something. Between that and my inability to get jdoom.dll to link in Release mode instead of Debug, I'm not sure how many cues you should be taking from me on the code side. ;) )

Also available in: Atom PDF