Project

General

Profile

Bug #467

Segmentation Violation

Added by technowolf almost 15 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
2007-08-14
% Done:

100%


Description

I'm using Doomsday v1.9.0-beta 5.1
EVERY time I run ultimate doom or doom2...after selecting new game, then selecting difficulty setting, the precache runs, and I get a "segmentation violation". Note that I've tried just vanilla ultimate doom & doom 2 with no add ons to be sure it was not a mod error.
EVERY time I run Plutonia or TNT, after the same basic game entry, I get a "Map MAP01 utilizes sidedef packing, which is currently unsupported" error.
I am attaching a text doc containing the "doomsday.out" text from each of the 4 errors.
Note as well that I have historically had no troubles on the same computer (no upgrades) running doomsday.
(I have recently reformatted my hard drive, and reinstalled all drivers, and no new/strange software.
I love doomsday's graphic quality, and would like to get this resolved....please help.

Labels: jDoom

History

#1 Updated by technowolf almost 15 years ago

doomsday.out errors from ultimate doom, doom2, plutonia, and tnt evilution

Attachments:

#2 Updated by yagisan almost 15 years ago

Logged In: YES
user_id=1248824
Originator: NO

'EVERY time I run Plutonia or TNT, after the same basic game entry, I get a
"Map MAP01 utilizes sidedef packing, which is currently unsupported"
error.'

That is not a crash - that is doomsday refusing to run an unsupported iwad (fixed for next version already),

I don't see an obvious reason for the segmentation violation for doom/doom2 - could you append a -v to the startup options for a more verbose doomsday.out

#4 Updated by technowolf almost 15 years ago

Logged In: YES
user_id=1867679
Originator: YES

Thanks for reply.
Excuse my ignorance: I've attached a txt file containing doom 1+2 doomsday.out files under the "Level 2" verbose setting shown under the "developer" options, assuming this gives the most possible information??
Thanks again.
File Added: Doomsday Out VERBOSE.txt

#5 Updated by yagisan almost 15 years ago

Logged In: YES
user_id=1248824
Originator: NO

I've looked at the verbose output, but it wasn't as helpful as I was hoping. If you try 1.9.0beta4 or try re-installing 1.9.0beta5.1 do you get the same error ? ( Segmentation Violation is a really useless message from the operating system to say something went wrong - it would be nice if it was more specific! )

#6 Updated by technowolf almost 15 years ago

Logged In: YES
user_id=1867679
Originator: YES

Tried 1.9.0-beta4, & reinstalling 1.9.0-beta5.1 with same results.
I WAS able to get a playable game using version 1.8.6 and even then only after installing directly to C:/Doomsday
If installed to C:/Program Files/Doomsday, there is a segmentation violation.
I went back immediately and tried 1.9.0-beta5.1 with an install to C:/Doomsday with same errors as posted in the text doc attachments.
For some reason, my system does not like Doomsday 1.9builds ?

#7 Updated by airacobra over 14 years ago

Logged In: YES
user_id=1930484
Originator: NO

I also get that segmentation violation error... in Plutonia, every time I go to save after some amount of play in a map, it throws that error, complaining of too many items.

#8 Updated by danij over 14 years ago

Logged In: YES
user_id=849456
Originator: NO

This isn't a bug. The map you are trying to play uses a feature not currently supported in 1.9.0-beta5.1 and Doomsday is shut down gracefully.

The issue has been resolved in the upcoming 1.9.0-beta6

#10 Updated by technowolf almost 14 years ago

I'm getting a segmentation violation with vanilla Ultimate Doom in V 1.9.0-beta5.1
Anyone help??
File Added: UltimateDoom VERBOSE.txt

Also available in: Atom PDF