Project

General

Profile

Bug #466

MUS Music skips on loop

Added by morbidmorre almost 15 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2007-08-06
% Done:

100%


Description

  • When a MUS file reaches the end of the song and loops back to the beginning there is a slight pause. (as if it is reloaded into memory?) There should be a seamless loop.
  • This works in Doomsday version 1.8.6, tried the same WAD on three different systems. It also skips with the original music in DOOM/DOOM2 IWAD. Don't know about Heretic/Hexen.
  • vanilla doom - no addons.

Labels: Music

History

#1 Updated by morbidmorre almost 15 years ago

Logged In: YES
user_id=1861760
Originator: YES

Sorry for my confusing report. The bug occurs in Doomsday 1.9.0-beta5.1 bot NOT in Doomsday 1.8.6

#2 Updated by danij almost 14 years ago

Logged In: YES
user_id=849456
Originator: NO

You are absolutely correct in that the pause is caused by the fact that every time the MIDI is played, it is (re)converted to MUS and then (re)loaded into memory.

We'll address this when we do the (much needed) audio overhaul.

#3 Updated by danij over 13 years ago

Now that the conversion is handled within the engine and only occurs when the current song changes this should now be fixed in svn for 1.9.0-beta6.

Also available in: Atom PDF