Project

General

Profile

Bug #445

WAD Loading/using problem

Added by epo35 about 15 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2007-05-07
% Done:

100%


Description

I got this WAD file and it works perfectly fine with doom95 and every thing loads right, but when ever I load/use it into the Doomsday Engine with JDoom I get some problems. The main problem is when ever I get to the exit of any level it crashes. I can load any level from the start, but it won't load the levels when i get to the exit or use cheat codes to skip levels. Anohter problem is not too big but some parts of the level just don't load. For example in level one of the WAD file there are some steps that all have holes in them when they are supposed to not have holes.

This is the error that pops up right after the game crashed.

Loading Sidedef Texture IDs....
Group Lines
Sector Look Up
Build Line and subsector tables
R_GetFlat:Lumnum = 2853 out of bounds(6)

I would upload it if it would let me. But the WAD is 1.347MB and when compressed its only 401KB.
So I uploaded it to geocities
http://geocities.com/nickharkins/STARGATE.zip

Labels: jDoom

History

#1 Updated by danij about 15 years ago

Logged In: YES
user_id=849456
Originator: NO

I've had a quick look at this and the problems are caused by the WAD itself, it is very poorly constructed and there are numerous parts of the map where sectors are not closed. I'll investigate to see if there is anything we can do to fix this type of map problem at run-time.

As for the crashing issue, I've been able to reproduce a crash using the latest svn version of Doomsday.

#2 Updated by danij about 15 years ago

Logged In: YES
user_id=849456
Originator: NO

All issues resulting in fatal errors with this PWAD have been resolved in svn for 1.9.0-beta6.

The issues with holes appearing in the level (missing segs) can only be resolved by first fixing the problems with the level structures (e.g. overlapping linedefs) and then rebuilding the nodes. I'm currently looking into the possibility of attempting to fix the errors automatically at load time.

Also available in: Atom PDF