Project

General

Profile

Bug #415

1.9.5.1 has a very odd behaviour in loading Pwad levels

Added by reilsss over 15 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
2007-02-12
% Done:

100%


Description

Hello, I don't know if this is a bug but it is something I noticed painfully.

I have a PWad level pack that makes with one map odd problems.
As I tested the pack in 1.9.4 everything worked perfect.
But in 1.9.5.1 I got a very odd experinces.

When I start new game and warp me from level 1 to the problem level that is level 2 I get this error

warp 02

Changing Level...
SetupLevel: MAP02
VerifyMapData: BEHAVIOR for "MAP02" could not be found.
Useable data will be generated automatically if needed.
DetermineMapDataFormat: (V2 GL Node Data)
(glBSP 2.20 | 2007-02-12 01:50:36.3900 | 0x78a8a795)
P_LoadMapData: MAP02
Loading Sidedef Texture IDs...
Group lines
Sector look up
Build line and subsector tables
R_InitLinks: Initializing
Segmentation Violation

But when I start a new game and warp into any other level first. As example level 3 or level 4. And warp then back into the problem level 2, I can load it perfectly.

So I do not understand whats wrong. The map seem to be ok, sinces it worked in 1.9.4. And it seem to work when I load after level 01 another level first like 03. But what does that have to do with loading a map at all?
I mean it can not be that one time the map makes an error, and another time it just runs perfectly. That sounds random to me.

I don't know how to explain this better. I feel that experinces it sell very weird. Specinaly sinces the old beta had not a kind of problem with it.

And befor I stop, I like to menton an oter familar map problem with another map of another mappack. In that other pack does it no matter from where I jump onto the problem map, the result is always that Doomsday freezes without any kind of error message by trying to load the map. I have to use ALT CRTL DEL to kill the froozen Doomsday task, and when I check after verboss 2 into doomsdayout. I can in that case not find a single note of thatsomething went wrong.

Sorry to report somany things in such a sort time.
I still admire the work the doomsdayteam is doing.
Best regards and good luck in seeing where something wrong with the newst beta

Labels: Data

History

#1 Updated by kresjah over 15 years ago

Logged In: YES
user_id=1179098
Originator: NO

I'm just adding this comment so that devs may read up on additional info on this issue. I've tracked down the error for one of the maps, and info is posted in this thread.

http://forums.newdoom.com/showthread.php?t=32491

#2 Updated by danij over 15 years ago

Logged In: YES
user_id=849456
Originator: NO

The second issue mentioned has been fixed in svn for beta6.

In order to track the first problem down I'll need to know where I can get a copy of the mod in question.

#3 Updated by danij about 15 years ago

Logged In: YES
user_id=849456
Originator: NO

I really do need more info on this in order to investigate.

#4 Updated by danij over 14 years ago

Logged In: YES
user_id=849456
Originator: NO

I'm assuming that this issue is no longer relevant in 1.9.0-beta6 so, closing accordingly.

If the issue persists please let us know.

Also available in: Atom PDF