Project

General

Profile

Bug #358

Hexen segfault in recent SVN

Added by zachkeene over 15 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
-
Start date:
2006-09-06
% Done:

100%


Description

Not sure when this crept in but it's still happening as
of 3854.

Start a game, VISIT02 (or play through normally if you
like), then take the first portal from Seven Portals to
the Guardian of Ice. Flip the switch in front of the
pendant, then step on the random blocks to return to
the Seven Portals.

At this point the console starts spewing a ton of
"R_FlatNumforName: <garbage characters> Not Found!"
errors and segfaults.

Backtrace and doomsday.out attached.

Labels: jHexen

History

#3 Updated by danij over 15 years ago

Logged In: YES
user_id=849456

Fixed in SVN.

#4 Updated by zachkeene over 15 years ago

Logged In: YES
user_id=1103163

It's still happening for me in 3914, and I don't think it's
me this time.

#5 Updated by danij over 15 years ago

Logged In: YES
user_id=849456

I noticed from your backtrace that you had just loaded a
save game. Can you try this without loading from an existing
save game.

#6 Updated by zachkeene over 15 years ago

Logged In: YES
user_id=1103163

I'm personally not loading any save; that's the automatic
save Hexen makes when I leave the Seven Portals, then
reloads when I attempt to return.

In a similar vein, you can VISIT03 to the Guardian of Ice
from the start, and return to the Sevel Portals with no
problem. But then any attempt to return to Guardian of Ice
will segfault.

#7 Updated by zachkeene over 15 years ago

Logged In: YES
user_id=1103163

Well, part of the problem is this: at several points in
sv_save.c, there's a check like:

if (saveVersion >= 3)
ver = GET_BYTE;

This check seems to always fail, for automatic
level-switching loads at least, because if I comment out the
if statements this problem goes away.

#8 Updated by danij over 15 years ago

Logged In: YES
user_id=849456

Ah I see what the problem is.

I've commited changes to SVN. Let me know if this fixes the
problem.

#9 Updated by zachkeene over 15 years ago

Logged In: YES
user_id=1103163

Yep, that fixed it. Thanks.

Also available in: Atom PDF