Project

General

Profile

Bug #356

HEXEN - DKODC - Mage - Segment Violation in MAP08

Added by stephenhowe almost 16 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
2006-09-03
% Done:

100%


Description

Hi

Hexen add on - Death Kings of Dark Citadel

This is a tricky bug and I believe may be caused by a
node building problem for MAP08 - "Constables Gate" -
start level of 2nd hub.
At the time I noticed it for Doomsday Engine version
1.8.6 but I believe the same problem occurs for the
latest 1.9.0.-Beta4

The cause of the violation I think is the "head" of
the Bloodscourge - the final segment of the 4th
weapon for the Mage.

Some background material
(i) Start a map editor and locate the "head" of the
Bloodscourge. It should be just before a teleport
to "Locus Requiescat".

(ii) Now if you visit there as Mage on the original
Hexen DKofDC, the "head" is present, bobbing

(iii) Now if you visit there as Mage on JHEXEN 1.8.6,
the "head" is missing and I have sometimes
seen "segment violation" on the map loads.

I think it is symptomatic of the problems playing
this level as Mage because JHEXEN tends to crash on
this level.

Stephen Howe

Labels: jHexen

History

#1 Updated by zachkeene almost 16 years ago

Logged In: YES
user_id=1103163

Works for me on Linux/SVN 3814.

#2 Updated by stephenhowe almost 16 years ago

Logged In: YES
user_id=1071665

I can demonstrate a difference between DKoDC (original
version) and JHEXEN version

1) Start DKoDC
2) Choose Mage, penultimate difficulty setting
3) Do VISIT08, SATAN, CASPER
4) Now walk to portal to Locus Requiescat.
5) In the original version of DKODC, the "head" of the
Bloodscourge will be bobbing in fromnt of the portal.
6) For JHexen it is missing. So where is it?

Stephen Howe

#3 Updated by zachkeene almost 16 years ago

Logged In: YES
user_id=1103163

I don't have 1.9.0beta4 or earlier around to check if
they're broken, but as of recent SVN versions the
Bloodscourge head is right where it should be, hovering just
above the floor in front of the portal.

Also available in: Atom PDF