Project

General

Profile

Bug #346

Overriding Map Info in addons (level par time; jdep)

Added by xero133 over 15 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Defect
Target version:
-
Start date:
2006-08-28
% Done:

0%

Tags:

Description

when playing with the jdep-20060601-1.pk3 addon when i
finish every level the par time is set at :05 seconds

just load the jdep-20060601-1.pk3 addon and finish a level

Labels: Definitions


Related issues

Related to Feature #1617: Scoped definitions and variablesNew2013-10-21

Related to Feature #1301: Redesigned DED ReaderProgressed2003-10-05

History

#1 Updated by danij about 15 years ago

Logged In: YES
user_id=849456

This has been semi fixed in SVN for 1.9.0-beta5.

The problem is that jDEP is missing par times from its
MapInfo definitions, this results in the rather unrealistic
goal of :05 par times :)

To improve the situation par time is not displayed at all if
not specified.

The jDEP should be updated to add the missing level par time
information.

#2 Updated by skyjake over 14 years ago

Logged In: YES
user_id=717323
Originator: NO

Where are the original par times? Shouldn't we fall back to those if they're missing in a MapInfo?

#3 Updated by danij over 14 years ago

Logged In: YES
user_id=849456
Originator: NO

The original par times have been removed from the source and added to the mapinfo definitions as discussed at the time.

The core of the issue is that there is no way to tie a given MapInfo to a particular map from a IWAD/PWAD. If we used the same indentifier in a MapInfo as used in Light definitions (of the form "mapid|game|pwad/iwad|gamemode") this would allow us to determine correctly whether there is a MapInfo for a specific map. If not found, then acceptable defaults could be chosen.

Falling back to the original par time for a map doesn't sound logical to me (plus we had a few user complaints about it). It seems to me that rather than display a par time which is wrong we should simply not. Similarly, if a map from a PWAD does not have a MapInfo specifying it's name; we should not display the name of the map used in the IWAD (and instead display something like: "SCYTHE:MAP01").

#4 Updated by skyjake over 14 years ago

Logged In: YES
user_id=717323
Originator: NO

I think we should devise some sort of a Global Resource Identifier string that we can apply uniformly to all resources, and not just maps in Light definitions. The "mapid|game|iwad/pwad|mode" string is a good start, but we should think carefully whether it is truly expressive enough in the future as well.

Here's a thought. What if the Global Resource Identifier was presented in the form of a URL, but into a completely imaginary file system? And include a URI in the beginning to define the type? Say, "map://jdoom/doom-ultimate/myfunmap/E2M3"? It would also be OK to use "map://jdoom/E2M3", or even "map://E2M3" which would cause the resource locator to look in the default places, and based on the WAD directory precedence order.

URLs seem like a tried and true scheme for identifying resources. (I'll go a create a DEW page for this...)

#5 Updated by skyjake over 9 years ago

Fixed in 1.9.7?

#6 Updated by danij over 9 years ago

No, this isn't fixed in 1.9.7

#7 Updated by skyjake over 9 years ago

Ah yes, this was about the definitions.

The earlier suggested solution of hiding the par time if undefined seems the best way to go before the definition system is redesigned/enhanced to cope with this situation.

#8 Updated by skyjake about 8 years ago

  • Tags set to Definitions, Mod
  • Subject changed from Overriding map info in addons (level par time; jdep) to Overriding Map Info in addons (level par time; jdep)
  • Category set to Defect
  • Target version deleted (1.9.0-beta6)

Is there support for, e.g.:

Map Info mods "E1M1" 
{
    ...
}

?

#9 Updated by danij about 8 years ago

No, presently the DED parser does not support the "mods" directive on MapInfo definitions (it should...).

#10 Updated by skyjake over 4 years ago

  • Status changed from New to Closed

Also available in: Atom PDF