Project

General

Profile

Bug #304

Doomsday crashes on wad (BSP problem)

Added by mrdarka about 16 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
2006-07-01
% Done:

100%


Description

Doomsday doesn't seem to run BSP automatically over wad
and crashes. Running bsp manually works.

End of output:
Opened PWAD file : bspcache/doom2/TESTX-E05E/MAP01.wad
Reading 11 dir entries at 0x176

Creating nodes using tunable factor of 7

Building GL nodes on MAP01

Loaded 4 vertices, 2 sectors, 8 sides, 4 lines, 1 things
Map goes from (-144,-156) to (116,32)
Creating Segs...
Built 4 NODES, 5 SSECTORS, 8 SEGS, 4 VERTEXES
Heights of left and right subtrees = (4,1)

Saving WAD as bspcache/doom2/TESTX-E05E/MAP01.gwa

Total serious warnings: 0
Total minor warnings: 4

All levels were built successfully.
VerifyMapData: BEHAVIOR for "MAP01" could not be found.
Useable data will be generated automatically if needed.
DetermineMapDataFormat: (V2 GL Node Data)
(glBSP 2.20 | 2006-07-01 23:17:15.0000 | 0xd9970749)
ValidateMapData: REJECT data is invalid.
P_LoadMapData: MAP01
Loading Sidedef Texture IDs...
Fatal signal: Segmentation Fault (SDL Parachute Deployed)

History

#2 Updated by danij about 16 years ago

Logged In: YES
user_id=849456

This is not a bug in Doomsday. The map itself is broken.

#3 Updated by mrdarka about 16 years ago

Logged In: YES
user_id=1042746

That may be because I've never mapped before my whole life...
However, I noticed this simply after moving a linedef in
MAP01 (Doom II). I think this may be a yadex problem, which
is unfortunate since it's the only working map editor in *NIX.

Also available in: Atom PDF