Project

General

Profile

Bug #294

Games listed on master do not show up in the browse lobby

Added by yagisan about 16 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
-
Target version:
Start date:
2006-06-01
% Done:

100%


Description

On *nix, when browsing master for multiplayer games to
connect to, none of the games appear the lobby.
Capturing network traffic shows the data being sent
from master, but they do not appear. Typing connect <ip
of a game listed at master> will connect to the game
(before usually getting discnnected due to other bugs)

Labels: Multiplayer

History

#1 Updated by yagisan over 15 years ago

Logged In: YES
user_id=1248824
Originator: YES

still present in svn 4407

#2 Updated by skyjake over 15 years ago

Logged In: YES
user_id=717323
Originator: NO

I believe the problem is that the master server response is received through a cache, which results in an HTTP header that Doomsday has difficulties in deciphering. If you're running a local cache, say squid, try turning it off and see what happens.

#3 Updated by yagisan over 15 years ago

Logged In: YES
user_id=1248824
Originator: YES

never had a local cache, but the ISP runs a transparent http proxy that can not be turned off. Reported several times in irc since beta5 came out now.

#4 Updated by danij over 15 years ago

Logged In: YES
user_id=849456
Originator: NO

Still present in svn 4474?

Also available in: Atom PDF