Project

General

Profile

Bug #280

Client Crashes Upon Joining of Network Game

Added by jason_scalia about 16 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Urgent
Assignee:
Category:
-
Target version:
Start date:
2006-05-29
% Done:

100%


Description

Using 2 win32 machines running clean installs of beta4,
I was able to replicate a crash that happens when a
client joins a network (co-op)game. Upon joining the
game, the client will immediately crash back to
windows. The server remained unaffected.

Labels: jDoom Multiplayer

History

#2 Updated by skyjake about 16 years ago

Logged In: YES
user_id=717323

I think there is an existing report about this problem. It has been around for a
while now... Must fix for 1.9.0.

#3 Updated by jason_scalia about 16 years ago

Logged In: YES
user_id=1163468

The last bit of info during testing in the .out file is as follows:
S-StartMusic: dm2ttl
N_InitService: In/Out UDP port 13209

I've tried in different os's and different ports etc and still the client crashes upon
joining. KuriKai also verified this during our testing.

#4 Updated by yagisan about 16 years ago

Logged In: YES
user_id=1248824

hmm. two beta4 boxes, both ubuntu reproduced this today.
Message from the other player was this:
(02:19:57) cbx33: ERROR Cl_HandlePlayerInfo: console:0
name:YAGISAN
(02:19:57) cbx33: Cl_HandlePlayerInfo: console:1 name:Player
(02:19:57) cbx33: psv_sync: gameTime=86.590
(02:19:57) cbx33: Doomsday 1.9.0-beta4 Server (R6)
(02:19:58) cbx33: Cl_Frame2Received: Unknown delta type 35.
(02:20:00) cbx33: Z_Shutdown: Used 1 volumes, total 33554432
bytes.
(02:20:45) cbx33: ping Yagisan

#5 Updated by jason_scalia about 16 years ago

Logged In: YES
user_id=1163468

I was actually able to play for a few moments using
plutonia.wad connecting from a linux (Fedora Core 5) hose to
a win32 server. I crashed with the following error:

ERROR Cl_HandlePlayerInfo: console:0 name:DIXIE NORMOUS
Cl_HandlePlayerInfo: console:1 name:JAY
psv_sync: gameTime=1.540
Doomsday 1.9.0-beta4 Server (R6)

Cl_Frame2Received: Unknown delta type 14.

Z_Shutdown: Used 1 volumes, total 33554432 bytes.

Looks like yagisan and I are seeing similar errors.

#6 Updated by skyjake about 16 years ago

Logged In: YES
user_id=717323

Unknown delta type errors fixed in revision 3341. Further problems with
multiple clients probably still remain, and will be investigated.

Also available in: Atom PDF