Project

General

Profile

Bug #271

The doomsday application crashes, it goes in a blocked state

Added by savbran over 16 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
2006-02-07
% Done:

100%


Description

If you play the 1st level with the map activated [tab]
of doom or ultimate doom, when the player reaches some
location, the doomsday application crashes (it goes in
a blocked state, i.e. the doomsday freezes) and no
action is allowed (such as esc, mouse clicks, etc.).
This is systematic (it always happens) and the only
thing that it's possible to do is to recall the task
manager from windows and kill the doomsday process.

It seems that the map can't be calculated in those
points and therefore the application freezes.

Thanks in advance for your attention and if you need
more details, don't hesitate to contact me.
Kind Regards
/Savbran

P.S.: testers can try it.

Labels: jDoom

History

#1 Updated by danij over 16 years ago

Logged In: YES
user_id=849456

Can you supply some more info about this crash please.

We'll need to know your system specs and what OS you're running.

Also can you post the contents of your Doomsday.out next
time the crash occurs.

Without the above information we can't diagnose the problem.

#3 Updated by savbran over 16 years ago

Logged In: YES
user_id=1445914

Hi, the system where the fault occurs:
- CPU: Pentium 4;
- Memory: 512Mb of RAM;
- Video board: NVidia Quadro FX 1300;
- Graphic sys: Directx9.0 and OpenGl;
- O.S.: Windows 2000

Yesterday I noticed that the fault occurs only when Opengl
is used. If I use Direct3D instead, it doesn't happen.
I have also attached the doomsday.out file.

Regards
/Savbran

#4 Updated by danij over 16 years ago

Logged In: YES
user_id=849456

Can you try Doomsday 1.9.0-beta3 (available from the files
section).

I've tried to reproduce this bug using Doomsday 1.9.0-beta3
using both the OpenGL and Direct3D renderers but have not
been able to thus far.

#5 Updated by savbran over 16 years ago

Logged In: YES
user_id=1445914

The fault is not present into the deng ver.1.9.0b3
so you can consider it fixed.

BRs

#6 Updated by danij over 16 years ago

Logged In: YES
user_id=849456

Apparently this bug has been fixed in 1.9.0

Also available in: Atom PDF