Project

General

Profile

Bug #2459

Incorrect Library libfluidsynth1 on Ubuntu 21.04

Added by XavierH about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Deng Team
Category:
Regression
Target version:
Start date:
2021-05-04
% Done:

0%


Description

Ubuntu 21.04 uses libfluidsynth2 as a MIDI library, while DEng uses libfluidsynth1 in its control file.
This leads to a broken deb database
Easy Fix :

dpkg-deb -R doomsday_2.3.1_amd64.deb doomsday_2.3.1
$EDITOR doomsday_2.3.1/DEBIAN/control
# fix libray version
dpkg-deb -b doomsday_2.3.1 doomsday_2.3.1_amd64-fixed.deb

HYH,
Cheers
Xavier


Related issues

Is duplicate of Bug #2431: Doomsday needs libfluidsynth1 but ubuntu 20.04 provides libfluidsynth2 onlyResolved2020-09-21

History

#1 Updated by skyjake about 1 year ago

  • Is duplicate of Bug #2431: Doomsday needs libfluidsynth1 but ubuntu 20.04 provides libfluidsynth2 only added

#2 Updated by skyjake about 1 year ago

  • Status changed from New to Closed

Closed as duplicate.

Also available in: Atom PDF