Project

General

Profile

Bug #2431

Doomsday needs libfluidsynth1 but ubuntu 20.04 provides libfluidsynth2 only

Added by eunbolt 7 months ago. Updated about 1 month ago.

Status:
New
Priority:
Normal
Assignee:
Category:
3rd party compatibility
Target version:
Start date:
2020-09-21
% Done:

0%


Description

Doomsday needs libfluidsynth1 but ubuntu 20.04 provides libfluidsynth2 only

dave@beast:/media/Downloads/Firefox$ sudo dpkg -i ./doomsday_2.3.0-build3486_amd64.deb
[sudo] password for dave:
Selecting previously unselected package doomsday.
(Reading database ... 384680 files and directories currently installed.)
Preparing to unpack .../doomsday_2.3.0-build3486_amd64.deb ...
Unpacking doomsday (2.3.0-build3486) ...
dpkg: dependency problems prevent configuration of doomsday:
doomsday depends on libfluidsynth1; however:
Package libfluidsynth1 is not installed.

dpkg: error processing package doomsday (--install):
dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.24-1ubuntu3) ...
Processing triggers for gnome-menus (3.36.0-1ubuntu1) ...
Processing triggers for mime-support (3.64ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for man-db (2.9.1-1) ...
Errors were encountered while processing:
doomsday
dave@beast:/media/Downloads/Firefox$ apt search libfluidsynth1
Sorting... Done
Full Text Search... Done
dave@beast:/media/Downloads/Firefox$ apt search libfluidsynth
Sorting... Done
Full Text Search... Done
libfluidsynth-dev/focal 2.1.1-2 amd64
Real-time MIDI software synthesizer (development files)

libfluidsynth2/focal,now 2.1.1-2 amd64 [installed,automatic]
Real-time MIDI software synthesizer (runtime library)

History

#1 Updated by skyjake 7 months ago

  • Category set to 3rd party compatibility
  • Assignee changed from Deng Team to skyjake
  • Target version set to 2.3

Should update the FluidSynth plugin to use version 2.

#2 Updated by skyjake 7 months ago

Looked into this. The problem is that the Autobuilder is running Ubuntu 18.04, where libfluidsynth2 doesn't exist. Doomsday itself is already working fine with FluidSynth version 2.

I'm inclined to discontinue Ubuntu packages built directly by the Autobuilder, and instead we could rely on Launchpad since that supports multiple different versions of Ubuntu.

#3 Updated by skyjake 7 months ago

  • Target version changed from 2.3 to Build system and tools

#4 Updated by eunbolt about 1 month ago

the doomsday download page needs updating to point to the launchpad page

#5 Updated by skyjake about 1 month ago

You mean http://dengine.net/linux ?

There is already a link to Launchpad under the Ubuntu section. I'm not sure how you are suggesting to update the page?

#6 Updated by eunbolt about 1 month ago

current linux page when viewed from ubuntu, those ubuntu builds download the installer that doesn't work on new ubuntu releases

Doomsday 2.3.1 — 64-bit deb
Ubuntu 18.04 (or later) · February 4

2.3 Unstable #3617 — 64-bit deb
Ubuntu 18.04 (or later) · 2020 November 27

#7 Updated by skyjake about 1 month ago

Ah I see. I suppose for now those should be labeled as "Ubuntu 18.04 – 19.10", or whichever release still had libfluidsynth1.

Also available in: Atom PDF